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This guide was created using QGIS 3.23.3 and with data from Kartverket, Norges Geologiske 
Undersøkelse and Statistisk Sentralbyrå.

The guide is published as CC-BY-SA. Note that if you are replicating images from the guide 
you need to cite both the guide and e.g. QGIS (for screenshots from the program) or the 
original data source (for maps) or both (for maps shown within QGIS).



Exercise 1: Getting started with QGIS

Although GIS programs are powerful programs capable of a wide range of analyses of 
geographical data, they are commonly used just to create maps that visualise geographical 
information. In this exercise we will go through the basics of map making as we produce the 
first maps that you will need for your course project. 

In this exercise you will learn how to:

• Install QGIS

• Get some tips on how to organize your files

• Create a new map

• Define the coordinate reference system for a map (CRS)

• Add vector data to a map

• Change the appearance of vector data

• Save and load a Style

• Export the map as an image

• Save the project

Data sources:

N50 Kartdata. Kartverket. Downloaded from N50 Kartdata - Kartkatalogen (geonorge.no) 
(2024-03-18), modified. 

Berggrunn N250. Norges geologiske undersøkelse. Downloaded from Berggrunn N250 -
Kartkatalogen (geonorge.no) (2024-02-26).

Løsmasser. Norges geologiske undersøkelse. Downloaded from Løsmasser - Kartkatalogen
(geonorge.no) (2024-02-26)
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Install QGIS

In this course we will use QGIS as our main geographical information system. If you have 
used other GIS programs such as ArcGIS before you will find many similarities.

• Go to Download · QGIS Web Site

• Select the offline (standalone) installer and choose the long term version for your 
operating system.

• Follow the download instructions and choose all the standard options.

Why are we using QGIS?

QGIS is a free, user-friendly, and open-source geographical information system. Because of 

this all of you will be able to access it for free also after you leave university. If you want to 

learn more I highly recommend: A Gentle Introduction to GIS — QGIS Documentation 
documentation

Organize your files

Before we start using QGIS we need to organize the data we will use. GIS programs generate 
a lot of files so making sure that they are named properly and stored in a logical place so that 
you can find them is important. Note that all the files you add in QGIS or create in QGIS are 
not actually stored in QGIS, they are stored wherever you saved them on your computer. If 
you rename or move your GIS files your maps will not work!

Make a folder for the course on the computer somewhere that is easy to find and where you 
won’t have to move it during the course. Name it e.g. “Landscape_analysis”
In it make another folder named e.g. “EE509_Exercise1” where you will save all your files 
from the first exercise.

Good folder and file names are:

• Descriptive, don’t just call your project Exercise1 as you will have an exercise 1 in many 
different courses, instead call it e.g. “EE509_Exercise1_v1”. This applies to all the files 
you generate through the project, name them something that make them easy to recognize 
(but not too long).

• Written without special characters (e.g. “-”, “ä”, “å”, “æ”, “ø”, “!” or blank space). 
Underscore “_” is ok.

It may seem unnecessary but doing it this way will help you to keep track of your files and 
avoid some annoying bugs.

Download all the data for the first exercise. It has been compressed, so after you have 
downloaded it you can right-click on the folder and select Extract/Pakk ut. Save it in the 
“EE509_Exercise1” folder you just made. Now we are ready to start using QGIS...
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Start a new project and select coordinate reference system

• Open QGIS and  select Project (top left corner) > New to start creating a new map.

The first thing we want to do is to define the coordinate system for the project.

• Click on Project > Properties and choose CRS in the menu to the left in the pop-up 
window.

• Choose ETRS89/UTM zone 33N in the list of predefined coordinate systems (you can 
write the name in the Filter box to search for it, note that there are several CRS with fairly 
similar names, use the one with ID: EPSG:25833). Click Apply and OK. Next time you 
should be able to find it in the list of Recently Used Coordinate Reference Systems.

What coordinate reference system (CRS) should you use for your project?

• If all your data is in the same CRS it is usually easiest to use that for your project.
• Vector data is easier to transform than raster data, so if you have important information as 

raster data it may be easiest to use the coordinate system of that layer.
• Use a coordinate system that is adapted to the scale and area that you are studying. 

ETRS89 / UTM zone 33N, which we will mostly use in this course, is for example well 
adapted for Norway but would be a poor choice if you have global data or if you are 
doing a study in Japan.

• Use a coordinate system that presents the coordinates in meters (instead of e.g. degrees), 
it will simplify calculations and avoid some problems.

In this course you should always use ETRS89 / UTM zone 33N unless stated otherwise.
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Add vector data to your map

Next, we want to start adding some information to the map. The first map layer we are 
adding is a layer showing the area cover, forests, farmlands, cities etc., in the county of 
Telemark.

• Layer -> Add Layer -> Add Vector Layer.

Vector data or raster data?

• Vector data means that the geometry of the object is stored as a series of interconnected 

vertices. Vector data can describe points, lines or polygons. Vector data is space efficient 

(smaller data files), easier to transform if you have to change coordinate system, and will 

look sharp no matter how far you zoom in.

• Raster data means that the information is stored as pixels. Raster data is useful if you 

have data that changes gradually, such as elevation or temperature. Raster data files can 

be very large.
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• Click on the three dots (1) and browse until you find the course files you downloaded 
previously. Select the file Area_cover.shp (.shp is a common file format for vector data, so 
that is generally the file you want for vector data in this course.)

• Click Add (2) and Close (3)

1
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• Your map should now look approximately like the one below, but perhaps with a 
different colour. Explore it by using the magnifying glasses to zoom in and out.

• Right click on your layer (Area_cover) in the Layers panel and select Open Attribute
Table

In the Layers panel all the layers in your 
map will be listed. Right now, you only 
have one, but when you have more you 
can use this panel to change the order of 
the layers by dragging them higher up or 
lower down in the list. You can also make 
a layer invisible by removing the check 
mark, or to make it visible by checking it 
again.
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• In the attribute table you can see all the information that is stored about the different 
objects in your map. At this stage we are mostly interested in area type. The second
column, objtype, indicates the area type in Norwegian, as this is a Norwegian dataset. I 
have added a column with an English translation, you can find the new column
areatype at the right end of the spreadsheet.  

• Close the attribute table.

• Right click on your Area_cover in the Layers panel and select Properties.

• Go to Source to see the CRS for the layer. In this case it should be the same as you project. 

Change the appearance of vector data

• Go to Symbology (1) and click on Simple fill (2). You will now get the option of changing
the stroke and fill. For an area map we don’t need a black border between the area types so 
change stroke style (3) to No Line and click Apply (4).
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• We don’t want all the area types to have the same color. Change from Single Symbol to 
Categorized (1). 

• We want the values in the column areatype to decide the color, change Value to the
correct column (2).

• Click Classify (3) to give each category a separate color.

• Click Apply (4) and take a look at your map. It should now be multicolored but the
color choices will most likely be very weird.

• Right click on the small color symbols next to each category (5) and select Change
Color. Select a fitting color for each category (e.g. green for forest, blue for lakes…).

• Also change the text in the Legend (6) to something more readable, e.g add
blankspaces where needed. 

• Click Apply (4) and then OK (7). Take a look at your new map.

• Project -> Save. Use a recognizable name and place it in a folder where you will find it 
again later. 

• Next we want to add roads etc. to the map. Layers -> Add Layers _> Add Vector Layer. 
Find the file Infrastructure.shp in your downloaded data. Add it to the map. Like the
previous layer this is a vector layer, but with lines instead of polygons.
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• Check that the new Infrastructure layer is on top of the Area-cover layer in the Layers
panel, otherwise it won’t be visible.

• Open the attribute table of the Infrastructure layer. 

• If you look at the column objtype it has two categories Bane (for railroads) and 
Veglenke (Road section), where Veglenke is used for all kinds of roads, from 
ferries to foot paths, but we don’t want all these types of roads to have the same 
symbol. In typeveg the different roadtypes have been categorized separately, but
here the railway is missing. Ideally we would want to use information from both
categories when we define the symbology.  

• Righ-click on your Infrastructure layer in the layers panel and select Properties

• Go to Symbology

• Change from Single Symbol to Categorized, just like you did for the previous layer.

• Choose Value: objtype and click Classify

• Click Apply. You now have different colours for roads and railroads, but all kind of
roads and paths looks the same. Remove the check marks for Veglenke and all othe
values, so that only the railway (Bane) is visible 

• Double-click on the symbol and look through the default sympols. There you will find
the symbol above which is a standard symbol used for railroads, use it.

• Righ-click on the Infrastructure layer in the Layers panel again and select duplicate
layer. You will get a copy of the layer, make it visible using the check box next to the
layer name.

• Open the Properties of the new layer. In Symbology, change the Value to typeveg
and click Classify. Disagree to delete the existing categories. 

• You now have a list of different road types (bilferje = car ferry, enkelBilveg = road, 
gangOgSykkelveg = bike and foot path, passasjerferje = passenger ferry, traktorveg = 
tractor road). Click on the sympols for each road type and choose a suitable color and 
symbology. If you click where it says Simple line you will get options for changing
line width and to make it into a dashed or dotted line.

• The all other categories variable will include the railways, which we have already dealt
with, uncheck it to make it invisible.

• Project -> Save (I will not keep reminding you to save, but you should do so often!)
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• Keep adjusting the colours and symbols until you are happy with the appearance of the
map.

• Also adjust the names in the Legend (go to Properties -> Symbology) so that they are
readable and in English.

Save your design as a style

Designing a good-looking layer can be a time-consuming process, especially when there
are many different variables. To save yourself from having to do the same thing over and 
over again you can save your design as a style. You can then load your style the next time 
you are using the same data, or other data organized in the same way.

• Go to Properties -> Symbology for the layer you want to save the design from.

• Click on Style in the bottom left corner and select Save Style…

• Save your style together with your other GIS files from the project and with a logical
name (e.g. Area_cover_style).

Export map as an image

• The easiest way to export a map is by using Project -> Import/Export -> Export map to 
image.

• The suggested extent is whatever is shown on screen at the moment, but you can
change these values, or select Map Canvas Extent to get the full extent or Draw on
Canvas to suggest a particular extent.

• The suggested resolution, 96 dpi is ok for web use but for print you should change it to 
300 dpi, unless you plan to only show it in a small format.

• Save

More advanced options for map design can be accessed by instead going to Project -> 
New Print Layout. This will open a new window where you can design a map inluding
scale bars, north arrow, legend, text boxes… I will not cover these options here but a 
good guide on how to use the Print Layout can be found here: 4.1. Lesson: Using Print
Layout — QGIS Documentation 

Add geological maps and load styles

Finally we will add two more vector layers, this time containing geological data.

• Layer -> Add Layer -> Add Vector Layer. Select Bedrock.shp from your course files.

Note that this layer only covers a part of the area covered by your area coverage map. 
Your area cover layer covers all of Telemark county whereas your geological layers where
cut so that they only cover the main study area.

• Properties -> Symbology -> Style -> Load Style and select the file bedrock_250 from 
your course files. The rock names are in Norwegian but you can find translations for 
the important ones at the back of this guide.
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There are a lot of rock types in the list, not all of them found around Bø, and it can be 
difficult to find out which one is which as the colours are fairly similar. Fortunately there
is a tool that can be used.

• Click on the layer you are interested in to make it active (1).

• Click on the Identify Features tool (2)

• Click on the feature you are interested in (3)

• Read all the information that is stored about the feature in the attribute table (4).

• In this case hovedbergart (hovedb… in the list) refers to the main rock type, in this
case a Karbonatitt (Carbonatite). 

• Next you should add the Quaternary sediments to the map. Find
Quaternary_sediments.shp among your course files and add it to the map (another
vector layer). 

• Use the Style sediments.qml from the course files.

• If you look at the map you can see that some areas are much more detailed than others, 
that’s because they have been mapped at different resolutions.

• It can be easier to navigate in the map if you can see the roads and railroads, move
them to the top of the list of layers in the Layers panel (drag and drop).

• Test using the check boxes in the Layers panel to show and hide different layers
depending on which layer you are interested in.

• You are done with the first exercise, save and quit QGIS.
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Exercise 2: Add and analyse raster data

In this exercise we will focus on raster data, datasets where the information is stored in 
pixels. 

In this exercise you will learn how to:

• Add raster data to a map

• Change the appearance of raster data

• Create a hillshade model

• Create a slope model

• Create an aspect model

• Show labels on a vector layer

Data sources:

Nasjonal detaljert høydemodell. DTM50. Kartverket. Downloaded from Høydedata 
(hoydedata.no) (2024-03-18)

Nasjonal detaljert høydemodell. DTM1. Kartverket. Downloaded from Høydedata 
(hoydedata.no) (2024-03-18)

N50 Kartdata. Kartverket. Downloaded from N50 Kartdata - Kartkatalogen (geonorge.no) 
(2024-03-18), modified. 

Berggrunn N250. Norges geologiske undersøkelse. Downloaded from Berggrunn N250 -
Kartkatalogen (geonorge.no) (2024-02-26).

Løsmasser. Norges geologiske undersøkelse. Downloaded from Løsmasser - Kartkatalogen
(geonorge.no) (2024-02-26)
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Return to a previous project

• Start QGIS

• Open your project from Exercise 1. You can either find it among recent projects on the
start page or use Project -> Open.

Add raster data to a project

Now it is time to add your first raster layer.

• Layer -> Add Layer -> New Raster Layer

• Find Study_area_1_dtm50.tif among your course files and click Add

• If you can’t see your new layer you should check its position in the Layers panel. If it 
is below one of your vector layers you either have to drag it to the top of the list or 
make the overlying layers invisible.

You should now have a layer that shifts in greyscale so that the highest pixel values are
white and the lowest values are black. In this case you have added a digital terrain model
(DTM) and the pixel values represent altitudes. Each pixel represents an area of 50*50 m. 
You will soon add raster data with a resolution of 1*1 m, but files at that resolution get
rather big, so to make things easier for your computers we only add those for the main
study areas.

• Zoom in enough so that you can see the individual pixels. 

• Activate your raster layer (click on it in the Layers panel) and use the Identify Feature
tool to identify the altitude (look for the value at Band 1).

• Zoom back out again.  

Change the appearance of a raster layer

• Right-click on your raster layer and select Properties -> Symbology.

Min value is automatically set so to the lowest pixel value in the data set and max to the 
highest value, i.e. altitude of the highest point (or in this case rather 50*50 m area, the 
actual peak can be higher). If you change them so that max is e.g. 1000 m all areas above 
1000 m will be white. This can be useful if you want to see the topography better in a 
specific altitude range and don’t care about what happen above or below, as more of the 
color gradient is then used in the interesting interval. 
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Greyscale can be useful for some applications but generally my preference for elevations
is to use a colour gradient instead. The one suggested below looks good for elevations but
may not be ideal if you have problem with color-blindness. 

• Change Render type to Single band pseudocolor

• Select a suitable color ramp, I usually use the one named Spectral for topography.

• Red should mark the high areas, not the low ones. Invert the color ramp by clicking on
the arrow next to the color ramp and selecting Invert Color Ramp. 

• Click Apply and OK to take a look at your results. 

Create a hillshade model

We can make the topography even clearer by adding a hillshade model. In a hillshade
model a raster is treated like a landscape with a topography where the high values are
higher areas (which in this case is accurate as our raster is a terrain model). A fictive
lightsource is then added to the landscape and the different pixels are lit up according to 
how much they are facing the lightsource. Much like the sun is lighting up actual
landscapes, giving some areas direct sunlight whereas other areas are shaded.

• Raster -> Analysis -> Hillshade

• Select your terrain model as Input layer (right now you only have one raster layer so it 
should be auto-selected, otherwise you can find it in the drop down list).

Azimuth of the light and altitude of the light determines where your fake sun will be 
positioned. Keep the standard settings for now but later it can be useful to make several
hillshade models with the azimuth of the sun e.g. 120 degrees apart, to highlight different 
parts of the landscape (features parallell to the light source will be much harder to see
than those that are transverse) 
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• Scroll down (1) to the bottom of the pop-up window and change where you want the
new raster to be saved by clicking opn the three dots (2) and select Save to file. Give it 
a good name and save it with your other project files. If you fail to do this step the
hillshade model will still be created, but as a temporary layer that will be gone the next
time you open the project.

• Click Run (3) and Close (4). 

• Take a look at your new layer, notice how it highlights the topography.

As it shows light and shade it makes sense to keep it in greyscale, but we can make it 
semi-transparent so that underlying layers are visible. 

• Right-click on you hillshade layer in the Layers panel and select Properties.

• Select Transparency and set Global Opacity to e.g. 50%.

• Click Apply and OK.

Being able to put the hillshade model on top of another layer and still see what is 
underneath can be highly useful as it gives an impression of the relief of the landscape at 
the same time as you see the information from the layer below.

• Use the Layers panel to rearrange your layers so that the layer directly underneath the 
hillshade layer changes. What information do you get by looking at hillshade + dtm? 
Hillshade + area cover? Hillshade + Quaternary sediments? Hillshade + Bedrock?

1
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Add the high-resolution terrain model to our map

• Layer – Add Layer -> Add Raster Layer

• Find Study_area_2_dtm1.tif among your course files. Add it to the map.

• Change the colour of it in the same way as you did with your previous raster. 

• Notice that the since max and min elevation are different than in your previous raster it 
won’t have the same colour for the same pixel value. You can change max and min so 
that they are the same as in your previous raster to make it look more coherent, but I 
would suggest leaving it as it is and only have one of the terrain models active at each 
time.

• Make a hillshade model for your new raster.

• Make the new hillshade model semi-transparent.

• Arrange the layers in the layers panel so that you have you new hillshade layer on top, 
followed by the dtm1 layer, then the previous hillshade layer and the dtm50 terrain 
model.

• Zoom in at the boundary between the two terrain models. Note how the dtm50 layer 
only shows the large landscape features whereas the dtm1 layer shows the landscape at 
an incredibly high resolution.

• Rearrange your layers again, this time so that you have the Quaternary sediments 
directly underneath your new hillshade. Try to see if you can find any pattern in how 
the landscapes with the different types of landforms look like? Can you see any 
difference between areas covered by peat and areas covered by bedrock? Which 
features are characteristic? Can you see anything in the topography that indicates that 
fluvial and glacifluvial deposits were deposited by running water? What features are 
characteristic for the marine deposits? Where do you find them in the landscape? The 
tills in this area are usually thin and hard to distinguish from the bedrock, can you see 
any difference between them?  

Add a new vector layer and show labels

• The map is starting to get complicated. Add the layer Study_area.shp to your map to 
start getting it organized (vector layer).

• Change the appearance so that there is no fill colour, just the polygon borders. 
Properties -> Symbology -> click on Simple fill -> Fill style: No brush

• Look at the attribute table, it has just a single column numbering the three study areas.

• Go back to Layer properties, select Labels. Change from No labels to Single Labels 
and use the Value id. Click Apply and close Layer properties.

• Now the three rectangles are numbered.

• Study area 1 is used to provide context and for low resolution GIS work.

• Study area 2 will be used for high-resolution GIS work. Most of your GIS work will be done for 
this area.

• Study area 3 is the area where we will do fieldwork. 
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Create an aspect model 

Aspect is the direction a slope is facing, e.g. whether it is a south slope or a north slope, 
something that is of importance for the vegetation. 

• Raster -> Analysis -> Aspect

• Use Study_area_2_dtm1 as you Input. Keep the standard options for the rest but save 
your aspect model as a new file, not as a temporary layer. Run the model. Look at the 
result.

As you can see the result is incredibly busy. That is because we are using a high-
resolution raster as our input data, which means that the smallest bump in the landscape 
gets a north side and a south side. Great if we are studying micro-climates, not so great if 
we are looking at larger patterns in the landscape. In addition, we have a problem in that 
the aspect model gives each pixel a value between 0 and 360 where 180 is a south facing 
slope and 0 and 360 are north-facing slopes. As the standard gradient goes from lowest 
value to highest value north-facing slopes are either black or white depending on whether 
they are facing slightly NNW or NNE. Ideally, we want all north slopes to be dark and all 
south slopes to be light. I have created a layer style called aspect.qml where north slopes 
are dark, south slopes light, east slopes red-orange and west slopes blue-green. You can 
load it in the same way as you loaded the styles for the vector layers previously.

• Layer properties -> Symbology -> Style -> Load Style -> aspect.qml

Next, we should do the same for our low-resolution raster (Study_area_1_dtm50).

•  Raster -> Analysis -> Aspect

• Use Study_area_1_dtm50 as you Input. Save your aspect model as a new file, not as a 
temporary layer. 

• Use the aspect.qml style and look at your results.

Create a slope model 

Next, we will create a slope map that shows where the terrain is steeper or flatter.

• Raster -> Analysis -> Slope.

• Use Study_area_2_dtm1 as input and save your results in a new file (not as a 
temporary layer).

The result is a raster where steep slopes are white and flat areas black. We could make it 
even more useful by making the aspect layer visible underneath. In the Style layer 
slope.qml I have made a gradient from opaque black for no slope and transparent white 
for a vertical slope, that is, flat areas will be very dark and steep areas will show 
whatever color is underneath. 

• Load slope.qml and use it for your layer.  

• Create another slope model for Study_area_1_dtm50 and style it in the same way.

• Try the various combinations of slope models and aspect models and decide which one 
you find most useful. I prefer using the combination of the high-resolution slope model 
and the low-resolution aspect model, but it also depends on how you plan to use the 
information.
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Save temporary layers

• Check if you see this symbol next to some of your layers in the Layers panel. If you do 
you have a temporary layer that will be gone the next time you open QGIS.

• Right-click on the layer and select Export -> Save as. Choose a good name and folder 
for your layer and save it using the standard options. A copy of the layer will have been 
added to the map, but you will have to load the Style again. 

Clean up your layers

You have now added several new raster layers to your map (your hillshade, aspect and 
slope maps are all raster layers) and especially the high-resolution ones are rather big 
files, some of your computers may start to feel the strain. However, as all the layers are 
saved on your computer, not inside QGIS, you can remove them from your project and 
then easily put them back again if you realize that you needed them.

• Remove the Study_area_1_aspect layer by right-clicking on it in the Layers panel and 
selecting Remove. 

• If you had any temporary layers that you saved previously the saved version will be a 
duplicate and the temporary layer will still be listed. Remove it.

• Keep the other slope and aspect layers but make them invisible.

• You are finished with part 2. Save your project and leave QGIS.

 

Study_area_2 (high-resolution) slope + Study_area_1 (low-

resolution) aspect.
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Exercise 3: Digitize data, create a new vector layer

Ditches used to drain wetter areas to make them more suitable for e.g. farming or forestry 
are common in the Norwegian landscape and have important influence on the hydrology, 
ecology and carbon cycle. In this exercise we will use some of the maps that you have created 
previously to help us identify ditches in the landscape and digitize them manually. The aim is 
to give you experience with interpreting hillshades and with manual digitization. 

In this exercise you will learn how to:

• Edit Attribute tables

• Create a new vector layer

• Digitize lines 

• Export Shapefiles

Data sources:

Statistiske rutenett 500m. Statistisk sentralbyrå. Downloaded Statistiske rutenett -
Kartkatalogen (geonorge.no) (2023-11-10), modified. 

Nasjonal detaljert høydemodell. DTM1. Kartverket. Downloaded from Høydedata 
(hoydedata.no) (2024-03-18)

Add and edit vector layers

• Add the two vector layers 500m_squares.shp and Ditches_study_area.shp

• Adjust the layer properties of both layers so that only the edges of the polygons are 
visible. Make the edge of the Ditches_study_area polygon thicker and in a different 
colour, so that you can tell the two layers apart.

• Open the attribute table for the 500m_squares layer. Click on the small pen symbol (1) to 
make it editable and add a new column by clicking on the New Field symbol (2). Name 
the column ditches and keep the Type as integer.

• Save your edits (3) and click on the pen symbol (1) again to stop editing.

1 23
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1       2      3      4      5      6       7      8       9

A

B

C

D

E

F

G

H

E9

I have given each 
square in the 
ditches study area a 
letter and number 
combination, to 
make it easier to 
discuss. 

Create a new vector layer

• Layer -> Create Layer -> New Shapefile Layer

• Give the layer a good name and select Geometry type LineString. Click OK
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• A pop-up window will open (see below), allowing you to add information to the layer’s 
attribute table. You can either leave it empty and just close the window, or write e.g. 0 for 
ditches you are uncertain about and 1 for the ditches you feel confident about. 

• Work your way systematically through the square you started on, carefully mapping all the 
ditches you see. In most cases the ditches are fairly easy to recognize, but there will 
always be some questionable features. Make your best guess and keep going, there will 
always be uncertainties when interpreting remote sensing data (and as it is an exercise it 
is ok if not everything is perfect).

• If you make a mistake and want to edit your line, you can use the vertex tool (4).

• Save your features (2) regularly, and always before you finish editing.

• Click on the pen symbol (1) again when you are done editing.

Find some features to add to your new layer

• First, we need to find some ditches. I think they are easiest to find on your high-resolution 
hillshade model (study area 2) so make that one visible and go to Layer properties -> 
Transparency and change the Global Opacity to 100%, to see as much as possible.

• The ditches are visible as small, elongated, often unnaturally straight lines in the 
landscape. They are most often found on flat terrain, as that is where water is collecting, 
but can be found in other places too. Below is an example from square E9.

Add features to your new layer

• Find your new layer in the Layers panel and click on 

it to activate it. Click on the pen symbol (1) to start 

editing.

• Click on the Add Line Feature symbol (3) to add a 

new ditch (if you create points or polygons instead of 

lines the symbol will look different, but you can find 

it in the same place).

• Click in one end of the ditch, and then again on the 

ditch anywhere it turns to create an accurate line. At 

the other end of the ditch, you can finish your line by 

right-clicking.

1     2                 3        4
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Export your results

I am interested in seeing your results from this exercise. In the next few steps you will 
export your data so that you can share it (if you want to).

• Right-click on the layer you want to export in the Layers panel. 

• Select Export -> Save Features As…

• Give it a good name and save it as an ESRI Shapefile using the standard settings 
(check that the CRS is still                                                            )

• Do this both for your Ditches layer and for your 500m_squares layer.

• Save your project and quit QGIS

E9 My interpretation of the 
ditches in E9.

• Activate the 500m_squares layer (click on it in the layers panel).

• Make it editable (1). Use the Select feature tool       and click on the square you were 
working on to select it (it should turn yellow).

• Click on Modify the attributes of all selected features          . A pop-up window will open 
where you can change all the information about the layer that is stored in the Attribute 
table. Scroll down to the new column Ditches that you created previously. Write 1 if you 
found any ditches and 0 if you didn’t. Click OK.

• Keep working systematically, square by square. Try to finish 5 squares. You can select 
squares from whatever part of the Ditches study area that you want.

• Save (2) and stop editing (1) both layers.

1     2                 3        4
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Exercise 4: Add data collected in the field or from the literature to your map

In this exercise you will learn how to:

• Add data from a spreadsheet into QGIS

• How to transform your data into another coordinate system

Data sources:

Nasjonal detaljert høydemodell. DTM50. Kartverket. Downloaded from Høydedata 
(hoydedata.no) (2024-03-18)

Nasjonal detaljert høydemodell. DTM1. Kartverket. Downloaded from Høydedata 
(hoydedata.no) (2024-03-18)

N50 Kartdata. Kartverket. Downloaded from N50 Kartdata - Kartkatalogen (geonorge.no) 
(2024-03-18), modified. 

Berggrunn N250. Norges geologiske undersøkelse. Downloaded from Berggrunn N250 -
Kartkatalogen (geonorge.no) (2024-02-26).

Løsmasser. Norges geologiske undersøkelse. Downloaded from Løsmasser - Kartkatalogen
(geonorge.no) (2024-02-26)

Statistiske rutenett 500m. Statistisk sentralbyrå. Downloaded Statistiske rutenett -
Kartkatalogen (geonorge.no) (2023-11-10), modified. 

Manually digitize data

If you know where a point should be placed, e.g. because you took a sample at  a road cross 
and you can find that point on the map, you can add your data in the same way as you 
digitized the ditches in the previous exercise.

• Create new vector layer, select point data, line data or polygon depending on what is most 
appropriate to your data.

•  Activate your layer and make it editable.

• Start adding features to your layer.

• Save layer and stop editing.
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Format your spreadsheet so that it is usable

You can add data from a spreadsheet, as long as it has the right format

• Create a new spreadsheet with your field data, or open an existing one

• Make sure that all columns have names and that the names are one word without special 
characters (underscores are ok, so SiteNo or Site_No both works, but Site No. does not).

• Decimal . should be used instead of decimal ,

• No cells can be merged

• There needs to be one column with X coordinates and another one with Y coordinates

• The coordinates needs to be written as numbers, not e.g. 59º24’N 

• Save your spreadsheet as .csv

Add data from a spreadsheet

• Layer -> Add Layer -> Add delimited text layer

• Find your file

• In Geometry Definition you must set the correct columns for the x coordinates
(horizontal/east-west) and y coordinates (vertical/south-north).

• You must also set the coordinate reference system, to do this you need to know, or guess, 
what coordinate reference system your data is in.

• If you used a GPS to collect the data, check the settings

• In published literature, usually as latitude and longitude, either presented in decimal
degrees (DD, 59.4103, 9.0618) or degrees, minutes, seconds ( DMS, 59º24’37.08’’N, 
9º3’42,48’’E). If presented as DMS, covert it to decimal degrees, e.g. using this
coverter: Coordinate Converter – Polar Geospatial Center (umn.edu). In QGIS 
decimal degrees is the default CRS: EPSG: 4326 – WGS84.

• If you don’t know, make a guess based on the coordinate systems that are common in 
your region, and see if the data shows up in a reasonable position.

When you have found the correct CRS and added your data the features can be used like any
other vector layer.
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Designing good maps

General design

• All maps should indicate the scale of the map. For digital maps a scale bar is usually 
the best option.

• Including a north arrow is a good practice, and necessary if you are not following 
the convention of having north at the top of the map.

• View-> Toolbars -> Annotations toolbar will give you options for adding and 
designing text in the map.

• Alternatively, the map can be exported in pdf format and opened in e.g. Inkscape (free) 
or illustrator where text etc. can be added. The latter option gives you even more 
choices when designing text and things surrounding the map, but it will make it really 
annoying if you ever have to change something in the actual map, so only do it if you 
are absolutely sure that you have created the final version of the map.

Colour choices

• Your colour choices will have a huge influence on how readable and visually pleasing 
your map is. Always make a conscious decision on what colours to use, don't just use the 
random colours that are assigned to the map when you create it.

• If there are generally agreed on colour choices or symbols for a certain feature (e.g. blue 
for water), you should use them, unless you have a strong reason not to.

• Always choose colours and symbols that are easily distinguishable from each other and 
clearly visible against the background.

• If you can make your colour choices visually pleasing and somehow related to what they 
are showing (e.g. yellow for observations of a yellow flower) it is even better, but this will 
not always be possible. Making it easy to read is more important.

• Remember that red-green colour blindness is common, if you are using both colours it is 
helpful to either use different symbols or to make one of them light and the other one dark.
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Frequent problems

Added layer is not visible

• Have you made it visible? Is there a check mark in the box next to it in the layers panel?

• Could it be hiding underneath another layer? Move it to the top of the stack in the Layers 
panel.

• Is it in the correct coordinate system? Zoom to full extent (Magnifying glass with arrows) 
and see if it shows up in the wrong place.

Missing layers when opening a map

Sometimes the program warns you about missing layers when you open your map. There are 
two common reasons:

• You may have moved your map or files (or renamed them) and now QGIS can't find them. 
You can click on the missing layer and show QGIS where to look for it.

• You created a temporary layer and forgot to save it the last time you used QGIS. If it 
showed the symbol to the right it was not saved, you have to create it again (and save it 
this time, either when you create it or afterwards by right-clicking on it in the layer list and 
selecting "Make permanent").

You are trying to run an analysis but it is not working

• Read the Frequent solutions

Frequent solutions

Are you using the same coordinate system (CRS) for the project and all your layers?

You can visualise data in different coordinate systems but many types of calculations etc. will 
only work if all the relevant layers are using the same CRS. If you have to add a layer that is 
originally in another CRS you can export it into the CRS used by your project. Right click on 
the layer in the Layers panel and choose Export -> Save features as. Give your layer a new 
name (perhaps one that indicate that you changed CRS?) and choose the CRS that you want 
the layer to be in. Make sure that the box with Add saved file to map is ticked and the 
exported data will be automatically added to your project. Now you have a copy of your data 
file but in the correct CRS.

Are you using a metric coordinate system?

If you are using a CRS where the basic units it e.g. degrees or feet instead of meters some 
calculations of areas, volumes, buffer zones etc. will fail or give very weird result. When you 
select a CRS you can also read the properties, make sure that the unit is meters. If you are 
using a CRS marked UTM ...., you are probably fine.

Did you get an error message?

Type the error message and "QGIS" into your search engine of choice. There is usually 
someone else who has had the same problem and may have found a solution.
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Useful data sources

Geonorge

The main source of Norwegian geodata

https://www.geonorge.no/

Høydedata

Download Norwegian LiDAR data. Point clouds, digital elevation models and digital surface 
models. View online or download.

https://hoydedata.no/LaserInnsyn2/

Geological survey of Norway

Geological maps for Norway. View online or download the data.

https://www.ngu.no/en

Artsdatabanken, species map

Species observations for Norway. View online or download the data.

https://artskart.artsdatabanken.no/

Natural Earth data

Free vector and raster map data at 1:10m, 1:50m, and 1:110m scales. Global coverage, good 
for creating small scale overview maps.

https://www.naturalearthdata.com/

Remember to reference your data sources for your maps!

Learn more about QGIS

A Gentle Introduction to QGIS

A Gentle Introduction to GIS — QGIS Documentation
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Lidar data- a very brief introduction

Lidar (Light detection and ranging) is a method 
where a laser beam is sent out from a lidar 
device mounted in e.g. a plane, on a drone or in 
a phone. When the laser beam hits an object it is 
reflected back and based on the time it takes for 
the light to return, the distance to the object can 
be calculated. As the laser beam moves over an 
area more and more reflections are measured 
and a point cloud can be created showing the 
positions of all the reflections.

This point cloud can be used to create a surface 
model over the area which shows the surfaces of 
all the measured objects. It is also possible to 
remove e.g. the reflections from vegetation, 
buildings etc. in the data and extract a terrain 
model which predicts the geometry of the 
ground surface. This is extremely useful in 
geology as it reveals geological landforms that 
may otherwise be obscured by the vegetation.

Example of Lidar measurements from an 
airplane.

Point cloud

Digital surface model

Digital terrain model
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Rock types (NO) Rock types (EN)

Amfibolitt Amphibolite

Basalt Basalt

Diabas Diabase

Dioritt Diorite

Gabbro Gabbro

Gneis Gneiss

Granitt Granite

Kalkstein Limestone

Karbonatitt Karbonatite

Kvartsitt Quartzite

Kvartsskiffer Quartz schist

Lamprofyr Lamprophyre

Larvikitt Larvikite (monzonite)

Leirskifer Shale

Leirstein Claystone

Rombeporfyr Romb porphyry

Ryolitt Rhyolite

Sandstein Sandstone

Syenitt Syenite

Amphibolite

Gneiss

Quartzite

Quartz schist

Limestone

Shale

Claystone

Sandstone

Basalt Lamprophyre

Diabase Larvikite (monzonite)

Diorite Romb porphyry

Gabbro Rhyolite

Granite Syenite

Karbonatite

Rhyolite Romb porphyry Basalt

Granite Syenite Diabase

Larvikite Gabbro

Diorite

Bedrock quick guide
Rock types found around Bø
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